using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\pZ\pC]+|[\pZ\pC]+$|(?! )[\pZ\pC]";
string substitution = @"";
string input = @" abc def ghi ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}