$re = '/(?<=\=%7)[A-Z]+(?=%)/U';
$str = 'onething=%7BABCDEFGHIJKLM%something=%7BNOPQRSTUVWXYZ%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);