package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(ID\:\ (?<resource_id>[a-z|\d|\ |\-]*[a-z])`)
var str = `module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)
module.kms_key.aws_kms_key.stack_key: Destruction complete after 22s
module.iam_profile.aws_iam_role.stack_iam_role: Destruction complete after 1s`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}