import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(ID\\:\\ (?<resource_id>[a-z|\\d|\\ |\\-]*[a-z])";
final String string = "module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)\n"
+ "module.kms_key.aws_kms_key.stack_key: Destruction complete after 22s\n"
+ "module.iam_profile.aws_iam_role.stack_iam_role: Destruction complete after 1s";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}