const regex = /\(ID\:\ (?<resource_id>[a-z|\d|\ |\-]*[a-z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(ID\\:\\ (?<resource_id>[a-z|\\d|\\ |\\-]*[a-z])', 'gm')
const str = `module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)
module.kms_key.aws_kms_key.stack_key: Destruction complete after 22s
module.iam_profile.aws_iam_role.stack_iam_role: Destruction complete after 1s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}