$re = '/^https?:\/\/((?:[a-z0-9](?:[a-z0-9-]{0,61}[a-z0-9])?\.)+[a-z0-9][a-z0-9-]{0,61}[a-z0-9])\/@([a-zA-Z0-9\_]+)\/(\d+)$/m';
$str = 'https://social.fossdle.org/@todbot@mastodon.social/109497770346696964
https://social.fossdle.org/@cogdog/109491626110489685
https://mastodon.ie/@lauramcdonnell/109496294552737622
https://twitter.com/ds106dc/status/1601902285226971137
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);