import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<link_all>\n"
+ " (?<!\\\\)\\[(?<link_name>.+?)(?<!\\\\)\\]\n"
+ " [ ]?\n"
+ " (?:\\n[ ]*)?\n"
+ " (?<!\\\\)\\[(?<link_id>.*?)(?<!\\\\)\\]\n"
+ ")";
final String string = "Foo [bar] [1].\n\n"
+ "Foo [bar][1].\n\n"
+ "Foo [bar]\n"
+ "[1].\n\n"
+ "Foo [bar][]\n\n"
+ "[Foo\\]][]\n\n"
+ "Here's one where the [link\n"
+ "breaks][] across lines.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}