const regex = /(?<link_all>
(?<!\\)\[(?<link_name>.+?)(?<!\\)\]
[ ]?
(?:\n[ ]*)?
(?<!\\)\[(?<link_id>.*?)(?<!\\)\]
)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<link_all>
(?<!\\\\)\\[(?<link_name>.+?)(?<!\\\\)\\]
[ ]?
(?:\\n[ ]*)?
(?<!\\\\)\\[(?<link_id>.*?)(?<!\\\\)\\]
)', 'gms')
const str = `Foo [bar] [1].
Foo [bar][1].
Foo [bar]
[1].
Foo [bar][]
[Foo\\]][]
Here's one where the [link
breaks][] across lines.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}