$re = '/(\d+\/?\d?+)/';
$str = '5
5/10
10/15/30
10/20/120
20/120/250/300';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);