using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<number_of_elements>\*\d)\\r\\n((\$\d)\\r\\n(\w+)\\r\\n)*";
string input = @"*2\r\n$5\r\nhello\r\n$5\r\nworld\r\n
*0\r\n
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}