const regex = /(?P<number_of_elements>\*\d)\\r\\n((\$\d)\\r\\n(\w+)\\r\\n)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<number_of_elements>\\*\\d)\\\\r\\\\n((\\$\\d)\\\\r\\\\n(\\w+)\\\\r\\\\n)*', 'gm')
const str = `*2\\r\\n\$5\\r\\nhello\\r\\n\$5\\r\\nworld\\r\\n
*0\\r\\n
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}