re = /^(?!.(.).*\1$)[ab]{3,}$/m
str = 'aaabbbbababab
aaabbbbababaa
ababbbbababab
ababbbbababaa
abb
aba
aab
aaa
a
ab'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end