import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[A-Z][A-Za-z:]*[^>]* ((?!class)[^ @]*)=[^>]*";
final String string = "<LinkTo @route=\"foo.bar\" @model={{this.model}} class=\"fancy-link\">\n"
+ " foo\n"
+ "</LinkTo>\n"
+ "<Input @checked={{this.isChecked}} @type=\"checkbox\" class=\"fancy-checkbox\" />\n\n"
+ "<Foobar class=\"fancy-foobar\" myArgument={{false}} as |foobar|>\n"
+ " <Foo @customerId={{this.model.id}} page={{50}} />\n"
+ " <Foobar class=\"fancy-foobar\" myArgument={{false}} />\n"
+ "</Foobar>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}