use strict;
my $str = '<LinkTo @route="foo.bar" @model={{this.model}} class="fancy-link">
foo
</LinkTo>
<Input @checked={{this.isChecked}} @type="checkbox" class="fancy-checkbox" />
<Foobar class="fancy-foobar" myArgument={{false}} as |foobar|>
<Foo @customerId={{this.model.id}} page={{50}} />
<Foobar class="fancy-foobar" myArgument={{false}} />
</Foobar>';
my $regex = qr/<[A-Z][A-Za-z:]*[^>]* ((?!class)[^ @]*)=[^>]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}