re = /<[A-Z][A-Za-z:]*[^>]* ((?!class)[^ @]*)=[^>]*/m
str = '<LinkTo @route="foo.bar" @model={{this.model}} class="fancy-link">
foo
</LinkTo>
<Input @checked={{this.isChecked}} @type="checkbox" class="fancy-checkbox" />
<Foobar class="fancy-foobar" myArgument={{false}} as |foobar|>
<Foo @customerId={{this.model.id}} page={{50}} />
<Foobar class="fancy-foobar" myArgument={{false}} />
</Foobar>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end