import Foundation
let pattern = #"<[A-Z][A-Za-z:]*[^>]* ((?!class)[^ @]*)=[^>]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<LinkTo @route="foo.bar" @model={{this.model}} class="fancy-link">
foo
</LinkTo>
<Input @checked={{this.isChecked}} @type="checkbox" class="fancy-checkbox" />
<Foobar class="fancy-foobar" myArgument={{false}} as |foobar|>
<Foo @customerId={{this.model.id}} page={{50}} />
<Foobar class="fancy-foobar" myArgument={{false}} />
</Foobar>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)