$re = '/\\\\hyperlink{([^}{]*)}{([^}{]*(?:{[^}{]*}[^}{]*)*)}/m';
$str = 'Use \\hyperlink{aaa}{apple {pear} banana} and \\hyperlink{bbb}{banana {pear} {apple}}.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);