package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\hyperlink{[^}{]*}{[^}{]*(?:{[^}{]*}[^}{]*)*}`)
var str = `Use \hyperlink{aaa}{apple {pear} banana} and \hyperlink{bbb}{banana {pear} {apple}}.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}