package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\p{L}+(?:\se\s\p{L}+)+`)
var str = `foo aáà e bbb bar baz ccc e ddd e eéè qux`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}