#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^\p{L}[\p{L}\p{M}\h().'&-]*$"
Local $sString = "first-second" & @CRLF & _
"first second" & @CRLF & _
"first'second" & @CRLF & _
"first & second" & @CRLF & _
"first&second" & @CRLF & _
"first(second)" & @CRLF & _
"first (second)" & @CRLF & _
"first-second-third" & @CRLF & _
"first second third" & @CRLF & _
"first second third(fourth)" & @CRLF & _
"first-second-third(fourth)" & @CRLF & _
"word Castaٌeda" & @CRLF & _
"Word Word (Word)" & @CRLF & _
"" & @CRLF & _
"Alfonso Lista (Potia)" & @CRLF & _
"Bacolod-Kalawi (Bacolod-Grande)" & @CRLF & _
"Balindong (Watu)" & @CRLF & _
"President Manuel A. Roxas" & @CRLF & _
"Enrique B. Magalona (Saravia)" & @CRLF & _
"Bacolod-Kalawi (Bacolod-Grande)" & @CRLF & _
"Datu Blah T. Sinsuat" & @CRLF & _
"Don Victoriano Chiongbian (Don Mariano Marcos)" & @CRLF & _
"Bulalacao (San Pedro)" & @CRLF & _
"Hinoba-an (Asia)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")