#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*\((.+?)\)(?: .*)$"
Local $sString = "(RA-B) RA-B三室两卫" & @CRLF & _
"(RA-B(NOC)) RA-B-NOC三室两卫" & @CRLF & _
"(RA-A) RA-A三室两卫" & @CRLF & _
"(RA-A(T)) RA-A(T)三室两卫" & @CRLF & _
"(more wicked) example" & @CRLF & _
"(WTF CODE CONTAINS WHITESPACES!) still it works" & @CRLF & _
"This (violates) the rule." & @CRLF & _
"(Needs a whitespace)after the parenthesis." & @CRLF & _
"((Nested) parentheses) causes unexpected results." & @CRLF & _
"(Badly (paired) parentheses ain't my fault."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")