Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
"
^\s*\((.+?)\)(?: .*)$
"
gm
Input 1
1
New
(RA-B) RA-B三室两卫 (RA-B(NOC)) RA-B-NOC三室两卫 (RA-A) RA-A三室两卫 (RA-A(T)) RA-A(T)三室两卫 (more wicked) example (WTF CODE CONTAINS WHITESPACES!) still it works This (violates) the rule. (Needs a whitespace)after the parenthesis. ((Nested) parentheses) causes unexpected results. (Badly (paired) parentheses ain't my fault.