# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*\((.+?)\)(?: .*)$"
test_str = ("(RA-B) RA-B三室两卫\n"
"(RA-B(NOC)) RA-B-NOC三室两卫\n"
"(RA-A) RA-A三室两卫\n"
"(RA-A(T)) RA-A(T)三室两卫\n"
"(more wicked) example\n"
"(WTF CODE CONTAINS WHITESPACES!) still it works\n"
"This (violates) the rule.\n"
"(Needs a whitespace)after the parenthesis.\n"
"((Nested) parentheses) causes unexpected results.\n"
"(Badly (paired) parentheses ain't my fault.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.