const regex = new RegExp('^([A-Z]+:)|[A-Z]+', 'gm')
const str = `TILL: LOOK we've got like a new bOArd`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);