re = /^([A-Z]+:)|[A-Z]+/m
str = 'TILL: LOOK we\'ve got like a new bOArd'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result