package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|[^0-9])(\(?0?[0-9]{2}\)?)?9 ?[0-9]{4} ?[0-9]{4}([^0-9]|$)`)
var str = `telefone (11) 9 9123 4567
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}