# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!`)((?:``)*)\$\(/$1`$$(/gi;t' <<< "<!doctype html>
<html lang=\"en\">
<head>
<body>
text
$computername
$username
text
$('unescaped')
`$('pre-escaped')
``$('unescaped')
```$('pre-escaped')
````$('unescaped')
</body>
</html>
"