$re = '/(?<!`)((?:``)*)\$\(/i';
$str = '<!doctype html>
<html lang="en">
<head>
<body>
text
$computername
$username
text
$(\'unescaped\')
`$(\'pre-escaped\')
``$(\'unescaped\')
```$(\'pre-escaped\')
````$(\'unescaped\')
</body>
</html>
';
$subst = "$1`$$(";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;