import Foundation
let pattern = #"(?<!`)((?:``)*)\$\("#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<!doctype html>
<html lang="en">
<head>
<body>
text
$computername
$username
text
$('unescaped')
`$('pre-escaped')
``$('unescaped')
```$('pre-escaped')
````$('unescaped')
</body>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1`$$("#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)