$re = '/(?<group>[a-zA-Z0-9\[\]=\+\-\¿\?¡!<>$%\^&\*\'"\sñÑáéíóúÁÉÍÓÚ]+)/m';
$str = '//abcdefghijklmnñopqrstuvwxyzñáéíóúABCDEFGHIJKLMNÑOPQRSTUVWXYZÁÉÍÓÚ0123456789[]=+-¿?¡!<>$%^&*\'()/#@*,.:;_| |||||||||| ] ¢£¤¥¦§¨©ª«¬®¯°±²³´µ¶¸¹º»¼½ mmmmm onload onclick=\'\' [ ? / < ~ # ` ! @ $ % ^ & * ( ) + = } | : ; \' , > { space !#$%&\'()*+,-./:;<=>?@[\\]^_`{|}~ <html>sdsd</html> ** *`` `` ´´ {} {}[] ````... ;;,,´\'¡\'!!!!¿?ña ñaña ÑA á é´´ è ´ 8i ó ú à à` à è`ì`ò ù & > < ksks < wksdsd \'\' \\" \\\' <script>alert(\'hi\')</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);