using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"A\S+\s([^:(]*)(?=:|\s\()";
string input = @"A1 muscle pain: immunotherapy'
A2B_45 muscle pain: topical medicine e.g. ....'
A2_45 muscle pain (pain): topical medicine e.g. ....'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}