// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)@import[ ]*['\"]{0,}(url\()*['\"]*([^;'\"\)]*)['\"\)]*"#).unwrap();
let string = "@import \"font-awesome.min.css\";
@import \"simple-line-icons.css\";
@import url(http://fonts.googleapis.com/css?family=Montserrat:700,400);
@import url('http://fonts.googleapis.com/css?family=ggg');
@import url(\"http://fonts.googleapis.com/css?family=ggg\");";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}