// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)<img\s+
(?=[^>]*\balt="(?<alt>[^>]*?)")? # optional alt attribute
(?=[^>]*\bclass="(?<class>[^>]*?)")? # optional class attribute
(?=[^>]*\bsrc="(?<src>[^>]*?)") # src attribute
[^>]*\/>"#).unwrap();
let string = "<img src=\"image.png\" alt=\"test\" style=\"zoom:55%;\" />
<img class=\"big\" src=\"image2.png\" />
<img alt=\"test\" src=\"image.png\" style=\"zoom:55%;\" />
<img src=\"image.png\" class=\"small\" style=\"zoom:55%;\" alt=\"test\" />
<img src=\"image.png\" alt=\"test\" style=\"zoom:55%;\" />
<img src=\"image.png\"
alt=\"test\"
style=\"zoom:55%;\" />";
let substitution = "{.${class}}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}