#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?!(?=[a-z]{3})[abc]{0,2}[^abc])[a-zA-Z])+$"
Local $sString = "abc" & @CRLF & _
"abcbcbcb" & @CRLF & _
"aaaaaaaa" & @CRLF & _
"AabcbaDEF" & @CRLF & _
"ABCDEFG" & @CRLF & _
"abcDEfgH" & @CRLF & _
"AbcDefG" & @CRLF & _
"" & @CRLF & _
"abcd" & @CRLF & _
"AbcdE" & @CRLF & _
"AabcbcdefgK"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")