$re = '/^(?!.*(?=[a-z]{3})[abc]{0,2}[d-z])[a-zA-Z]+$/m';
$str = 'abc
abcbcbcb
aaaaaaaa
AabcbaDEF
ABCDEFG
abcDEfgH
AbcDefG
abcd
AbcdE
AabcbcdefgK';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);