re = /^(?!.*(?=[a-z]{3})[abc]{0,2}[d-z])[a-zA-Z]+$/m
str = 'abc
abcbcbcb
aaaaaaaa
AabcbaDEF
ABCDEFG
abcDEfgH
AbcDefG
abcd
AbcdE
AabcbcdefgK'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end