use strict;
my $str = 'வெ/NN கலைவாணன்/NN திருப்பத்தூர்/NN செய்தியாளர்/NN சிவகங்கை/NNP மாவட்டம்/NN.
அழியும்/NNP நிலையில்/CNJ உள்ள/VNAJ விளையாட்டுக்களுக்கு/NN புத்துணர்வு/NN அளித்து/VNAV இருக்கிறது/VF கொரோனா/NN.
சிவகங்கை/NNP மாவட்டம்/NN திருப்பத்தூர்/NNP அருகே/ADV கிராமப்புறப்/NN பகுதிகளில்/CNJ கொரோனா/NN தொற்றுநோய்/NN தடுப்பு/NNC நடவடிக்கையான/NNC ஊரடங்கு/NN உத்தரவால்/CNJ அழியும்/VNAV நிலையில்/CNJ உள்ள/VNAJ கிராமங்களில்/CNJ மண்மணம்/NN மாறாத/VNAJ பாரியம்பரியமிக்க/NN விளையாட்டுக்களுக்கு/NN புத்துணர்வு/NN அளித்து/VNAV இருக்கிறது/VF கொரோனா/NN தமிழ்நாட்டு/NNP கிராமங்களில்/CNJ
மண்மணம்/NN மாறாத/VNAJ பாரியம்பரியமிக்க/NN விளையாட்டுக்களான/NN தாயம்/NN ஆடலாமா/NN சொட்டாங்கல்/NN விளையாடலாமா/NN என/CNJ இன்றைய/ADJ சிறுவர்களிடமோ/NN இளைஞர்களிடமோ/NN கேட்டால்/CVB அவர்கள்/PRP புரியாதது/NN போல்/PPO விழிப்பது/NN நாம்/PRP அறிந்ததே/ADJ.
அந்த/DET அளவிற்கு/NN பாரம்பரிய/NNC விளையாட்டுக்கள்/NNC என்னவென்றே/NN தெரியாத/VNAJ நிலைதான்/NN இன்றைய/ADJ இளைஞர்களிடம்/NN உள்ளது/CNJ தற்போது/ADV.
இந்த/DET விளையாட்டுக்கள்/NN அனைத்தும்/NN அருகி/VNAV விட்டன/NN.
ஆனால்/CNJ இந்த/DET விளையாட்டுகளுக்கு/NN மீண்டும்/ADV உயிர்/NN கொடுத்துள்ளது/VF கொரோனா/NN ஊரடங்கு/NN.
உத்தரவால்/CNJ வீட்டிற்குள்ளேயே/NN முடங்கிக்/VNAV கிடக்கும்/VNAJ கிராமத்தார்கள்/NN பாரம்பரியமிக்க/NN பழமையான/ADJ தனி/ADJ விளையாட்டான/NN தாயம்/NN விளையாடுதல்/NN பல்லாங்குழி/NN சொட்டாங்கல்/NN உள்ளிட்ட/ADJ விளையாட்டுக்களை/NN தனது/PRP வீட்டில்/CNJ உள்ள/VNAJ நபர்களுடன்/NN விளையாட/NN ஆரம்பித்துள்ளது/VF பழங்காலத்திற்கு/NN திரும்பியுள்ளதை/NN நினைவுபடுத்தியுள்ளது/NN.
வயதானவர்கள்/NN தங்களது/PRP பேத்திகளுக்கு/NN சொல்லிக்/VNAV கொடுக்கும்/VNAJ தாயம்/NN விளையாட்டில்/CNJ தற்பொழுது/ADV மாணவர்களும்/NN குழந்தைகளும்/NN ஆர்வம்/NN காட்டி/VNAV வருகின்றனர்/NN.
அதே/PRP போன்று/ADV கூட்டாக/ADV இல்லாமல்/VNAV வீட்டிற்குள்ளும்/NN வாசல்/CNJ முன்பு/ADV உள்ள/VNAJ மரநிழலில்/NN இதுபோன்ற/PRP பழமையான/ADJ விளையாட்டுகளிலும்/NN பெற்றோர்கள்/NN பாட்டிகள்/NN சகோதரிகள்/NN இணைந்து/VNAV விளையாடி/NN வருகின்றனர்/NN.
கொரோனா/NN பல/NNQ விதத்தில/NN பிரச்சனை/NN என்றாலும்/COM
பழமையான/ADJ விளையாட்டுகளை/NN சிறுவர்களுக்கு/CNJ கற்று/VNAV கொடுக்கும்/VNAJ நிலையை/NNC உருவாக்கியுள்ளது/VINT.
';
my $regex = qr/(.*(DET|NN*)*?)./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}