package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(http(s)?:\/\/.)?(www\.)?[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b([-a-zA-Z0-9@:%_\+.~#?&//=]*)`)
var str = `Get URL: www.lapagina.com, pagina.com, http://www.lapagina.com, http://pagina.com https://mypag.us`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}