re = /([#]+)\s*([^!]*)\s*(!\[.*\].*\))([^\n]*)/m
str = '## Another Letter From The Editor
## Another Letter From The Editor '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end