import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-?\\b\\d+(?:\\.\\d+)?(?:\\|\\-?\\d+(?:\\.\\d+)?){3}\\b";
final String string = "13|5|-1|3 or 5|5|0|3 or 13|4|1.5|1\n\n"
+ "The string may also contain additional numbers and words; a full example looks like so:\n\n"
+ "SOME STRING CONTENT 13|5|-1|3 MORE 1.6 CONTENT HERE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}