$re = '/^(?![a-zA-Z]+$).*/m';
$str = 'abcba1a
111111111111111111111
aaaaaaaaveeEEEEEEEE
ZzZ1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);