re = /^(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=.*?[^\w\s]).{8,}$/
str = 'wachtw00RD!'
# Print the match result
str.match(re) do |match|
puts match.to_s
end