// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([3-9][0-9]{3}|2[1-9][0-9]{2}|20[3-9][0-9]|202[1-9])-[0-9]{2}-[0-9]{2}|2020-1[0-9]-[0-9]{2}|2020-09-2[2-9]").unwrap();
let string = "2019-09-22
2020-08-22
2020-09-21
2020-09-22
2020-09-23
2020-10-22
2021-09-22";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}