#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\G(?!^)\s*,\s*|types:(?:\s*\[)?\s*)"([^"]*)""
Local $sString = "fd types:["a"] " & @CRLF & _
"s types: " & @CRLF & _
" ["b","c"]" & @CRLF & _
"types: [" & @CRLF & _
""one"" & @CRLF & _
"]" & @CRLF & _
"types: "two"" & @CRLF & _
"types: ["three", "four", "five","six"]" & @CRLF & _
"no: ["Don't","read","this"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")