$re = '/(?:\G(?!^)\s*,\s*|types:(?:\s*\[)?\s*)"([^"]*)"/m';
$str = 'fd types:["a"]
s types:
["b","c"]
types: [
"one"
]
types: "two"
types: ["three", "four", "five","six"]
no: ["Don\'t","read","this"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);