# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s+,?\[([A-Za-z0-9]+)\]\s=\s([A-Za-z0-9\@]+),?"
test_str = (" [UserLoginName] = @UserLoginName, \n"
" ,[UserExternalId] = @UserExternalId\n"
" ,[UserName] = @UserName\n"
" ,[Password] = @Password\n"
" ,[IsWindowsUser] = @IsWindowsUser\n"
" ,[Active] = @IsActive\n"
" ,[MustChangePassword] = @MustChangePassword\n"
" ,[PasswordExp] = @PasswordExp\n"
" ,[PasswordModifiedDate] = @PasswordModifiedDate\n"
" ,[PasswordPolicyName] = @PasswordPolicyName\n"
" ,[LoginTry] = @LoginTry\n"
" ,[PermissionsRefreshDate] = @PermissionsRefreshDate\n"
" ,[FirstName] = @FirstName\n"
" ,[LastName] = @LastName\n"
" ,[EmailAddress] = @EmailAddress\n"
" ,[DefaultStoreId] = @DefaultStoreId\n"
" ,[EmployeeNumber] = @EmployeeNumber\n"
" ,[Phone] = @Phone\n"
" ,[MobilePhone] = @MobilePhone\n"
" ,[Address1] = @Address1\n"
" ,[Address2] = @Address2\n"
" ,[PostalCode] = @PostalCode\n"
" ,[PostalAddress] = @PostalAddress\n"
" ,[Title] = @Title\n"
" ,[Language] = @Language\n"
" ,[BirthDate] = @BirthDate\n"
" ,[EmploymentDate] = @EmploymentDate\n"
" ,[ResignationDate] = @ResignationDate\n"
" ,[BankaccountNo] = @BankaccountNo\n"
" ,[SocialSecurityNo] = @SocialSecurityNo\n"
" ,[Comment] = @Comment\n"
" ,[Country] = @Country\n"
" ,[vudGUID] = @VudGUID\n"
" ,[CreatedByUserId] = @CreatedByUserId\n"
" ,[ModifiedByUserId] = @ModifiedByUserId\n"
" ,[CreatedDate] = @CreatedDate\n"
" ,[ModifiedDate] = @ModifiedDate\n"
" ,[UseSingleSignOn] = @UseSingleSignOn\n"
" ,[Salt] = @Salt\n"
" ,[IsSystemUser] = @IsSystemUser")
subst = "[\\1] = ISNULL(\\2, [\\1]),"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.