$re = '/https?:\/\/.*?[\r\n]*[\s?]/m';
$str = 'https://a.com/f sample words here https://b.com/g haha https://c.com/h ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);