#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{2}\/\d{2})\s*(\d{1,2}:\d{2}\s*(PM|AM))\s*(\d+)\s*([^\d.]+)(\d+)\s*([^\d.]+)$"
Local $sString = "12/16 7:00 PM 751 Appalachian State 752 Duke" & @CRLF & _
"12/16 7:00 PM 753 Chicago State 754 Indiana-Purdue" & @CRLF & _
"12/16 8:00 PM 755 Texas-Arlington 756 Oral Roberts" & @CRLF & _
"12/16 10:00 AM 757 Dartmouth 758 Stanford"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")