using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)/export/home(?:(?!/export/home).)*";
string input = @"/export/home/bla ""123"" ""bla"" test 1
/export/home/bla ""123"" ""bla"" test 2
/export/home/bla ""123"" ""bla"" test 3
test4
test5
/export/home/bla ""123"" ""bla"" test 6
/export/home/bla ""123"" ""bla"" test 7
/export/home/bla ""123"" ""bla"" test 8
test9
/export/home/bla ""123"" ""bla"" test 1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}