import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)/export/home(?:(?!/export/home).)*";
final String string = "/export/home/bla \"123\" \"bla\" test 1\n"
+ "/export/home/bla \"123\" \"bla\" test 2\n"
+ "/export/home/bla \"123\" \"bla\" test 3\n"
+ "test4\n"
+ "test5\n"
+ "/export/home/bla \"123\" \"bla\" test 6\n"
+ "/export/home/bla \"123\" \"bla\" test 7\n"
+ "/export/home/bla \"123\" \"bla\" test 8\n"
+ "test9\n"
+ "/export/home/bla \"123\" \"bla\" test 1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}